Подключение по локальной сети или Ethernet – «Подключено», но интернет не работает (красный крестик)

Расскажу вам как решить одну проблему, с которой сегодня столкнулся сам. Интернет к компьютеру (в моем случае это ноутбук) подключен по сетевому кабелю. Включаю компьютер и вижу, что интернет не работает. Возле иконки подключения в трее стоит красный крестик. Интернет у меня подключен от маршрутизатора. Думаю, это не имеет значение. Кабль может быть подключен напрямую от интернет-провайдера.

Это все в Windows 7. Так как у меня на компьютере установлено две системы, то загружаюсь в Windows 10 не отключая кабель и там интернет работает. Значит проблема точно не в кабеле, не в роутере (у вас может быть подключение напрямую) и не в сетевой карте компьютера. Значит что-то в сетевых настройках Windows 7, или с драйвером сетевой карты. Вот так выглядит статус подключения (или будет значок Wi-Fi, если он есть на вашем компьютере):

Красный крестик на иконке интернета (LAN)

Возможно, статус у вас будет "без доступа к интернету", или "ограничено" с желтым восклицательным знаком Статус подключения "ограничено". Можете применить решение из этой статьи. Если не поможет, то смотрите решение этой проблемы на примере Windows 10 в статье «Подключение ограничено» в Windows 10 и для Windows 7 – в этой статье.

Сетевой кабель подключен, все включено и должно работать. Вытянул кабель, подключил обратно – не работает.

Не работает интернет по кабелю на ноутбуке

Ну ладно, думаю, может система вообще не видит, что сетевой кабель подключен. Такое бывает, писал об этом в статье Сетевой кабель не подключен. Что делать, если он подключен но не работает. Дальше еще интереснее. Захожу в "Сетевые адаптеры" а там возле "Подключение по локальной сети" (в Windows 10 это "Ethernet") статус "Подключено".

Подключение по локальной сети или (Ethernet) со статусом "Подключено"

Вот это уже странно. Открываю "Состояние" адаптера (нажав на него правой кнопкой мыши) "Подключение по локальной сети" (у вас это может быть "Ethernet") и вижу, что IPv4: не подключено. Принято и отправлено пактов – 0. Не редко бывает, когда статус IPv4 без доступа к интернету или сети. На IPv6 можно не обращать внимание, если интересно, то подробнее читайте здесь. Но в данной ситуации все немного иначе.

IPv4: не подключено

Попробовал отключить и заново включить "Подключение по локальной сети" (через меню, которое вызывается нажатием правой кнопки мыши по адаптеру), дальше удалил сетевую карту с диспетчера устройств и перезагрузил компьютер, сделал сброс сетевых настроек – ничего не помогло. Но решение я все таки нашел. Когда решил проверить компоненты этого подключения.

Как я решил эту проблему с сетевым подключением

Открыл свойства "Подключение по локальной сети" (напомню, что в вашем случае это может быть "Ethernet").

Свойства "Подключение по локальной сети"

И в списке компонентов увидел "NDISKHAZ LightWeight Filter". Точно знаю, что подобных компонентов там быть не должно. Убрал галочку воле "NDISKHAZ LightWeight Filter" (отключив) его и нажал "Ok".

Лишний компонент из-за которого сетевой кабель подключен но интернет не работает

Интернет сразу заработал. Возможно, понадобится еще перезагрузить компьютер. Вместо статуса "Подключено" появилось название сети (роутера). А иконка подключения в трее стала нормальной.

Не идет передача пакетов по сетевому подключению (LAN)

У вас там может быть какой-то другой "странный" компонент. Просто попробуйте его отключить, ничего страшного не случится. Если не поможет – включите обратно. Это еще антивирус Avast любит подсунуть туда свой компонент, из-за которого подключение без доступа к интернету.

Как позже выяснилось, компонент "NDISKHAZ LightWeight Filter" (из-за которого не работал интернет по локальной сети) появился после установки программы MyPublicWiFi, о которой я собираюсь писать статью. Возможно, такую же проблему могут спровоцировать и другие программы, с помощью которых можно раздавать интернет по Wi-Fi. Или программы, которые каким-то образом интегрируют свои сетевые настройки в Windows.

Буду очень рад, если мой опыт вам пригодится. Пишите в комментариях!

Похожие статьи
Задать вопрос по статье
Комментарии: 40
Имя
28.09.2018 в 20:53 (9 месяцев назад)

Спасибо помогло! Компонент правда, другой был, но его отключение помогло.

Сергей
28.09.2018 в 21:41 (9 месяцев назад)

Пожалуйста! А какой у вас был, если не секрет?

Юлия
14.10.2018 в 10:32 (8 месяцев назад)

У меня это красный крест появился ни с того ни с сего, режим самолёта не включен. Нет слов » беспроводная сеть вообще» в сетевых подключениях

Сергей
14.10.2018 в 14:20 (8 месяцев назад)

Извините, но с вашего сообщения понять проблему невозможно.

Юрий
18.10.2018 в 13:23 (8 месяцев назад)

День добрый!
Проблема: пропадает соединение LAN через сетевую карту PCI-E x1. Все работает через сетевую на материнской плате (Х79). При включении внешней сетевой — сначала все работает, инет есть, но спустя какое-то время (по разному) сеть пропадает (красный крест-сетевой кабель не подключен), но диоды сетевой светятся. До переустановки Win 10, при разрыве сети еще и синий экран выскакивал с последующей перезагрузкой. Драйвера были установлены как автоматически так и через утилиты (свежайшие). Сетевая RTL 8114 v4/

Сергей
18.10.2018 в 16:51 (8 месяцев назад)

Добрый день. Если драйвера новые и через встроенную сетевую карту все работает, то скорее всего такие проблемы из-за аппаратных проблем с сетевым адаптером, который подключен через PCI-E. В другой слот PCI-E не пробовали ее подключать (если есть свободный), или на другом компьютере тестировать?

Могу посоветовать еще заменить драйвер на другой для этой карты из списка уже установленных. Подробнее читайте здесь. Обратите внимание, что статья написана на примере Wi-Fi адаптера. А вы будете все делать для LAN.

Наталья
24.10.2018 в 22:43 (8 месяцев назад)

Подскажите как быть, пожалуйста. Подключаю ПК к интернету через кабель. ip адрес настроен.

Сергей
25.10.2018 в 12:49 (8 месяцев назад)

Подключаете через роутер, или как? Что значит «ip адрес настроен»? Вы прописали статические адреса? Зачем?

По ошибке вроде как проблема с DNS. Вот инструкция с решениями: ошибка «DNS PROBE FINISHED NO INTERNET»

Александр
05.11.2018 в 00:01 (7 месяцев назад)

Здравствуйте , у меня хорошо работал интернет , и вдруг загорелся красный крестик и перестал работать интернет . С кабелем всё хорошо , не пойму в чём проблема 😕

Сергей
05.11.2018 в 14:28 (7 месяцев назад)

Здравствуйте. На каком устройстве? По кабелю от этого роутера (если подключение через роутер) на других устройствах интернет работает?
Попробуйте вытянуть и обратно подключить кабель. Перезагрузите роутер. Подключите кабель в другой порт на роутере.
Возможно, сгорела сетевая карта.

Ерема
13.11.2018 в 10:13 (7 месяцев назад)

Здравствуйте. У меня локальный сеть на 50 ПК. В 4 точках беспроводные стоит. Всю систему перезагружаю в беспроводных раздает интернет. И через где то минут 2, перестает раздавать. А по LAN есть. Серверов проверил и перенастроил. Все в норме как положено. Не могу понять что происходить. Из за этой проблемы менял коммутатор и кабелей. Что можете советовать?

Сергей
13.11.2018 в 12:23 (7 месяцев назад)

Здравствуйте. Ничего не могу советовать в этой ситуации. Это глупо. Там большая сеть, к которой у меня нет доступа. Откуда же мне знать, в чем там проблема.

Саша
16.11.2018 в 22:03 (7 месяцев назад)

Добрый день. Столкнулся с проблемой , На моём ноутбуке Samsung всегда Была беспроводной подключении к сети . Перестал пользоватся ноутбуком , Потом вновь запустила его , Если чего подключиться к интернету я мог только через кабель . Но как я вышел указал да этого я всегда пользовался беспроводным подключением к сети то-есть через роутер. Подскажите пожалуйста , Что делать в такой ситуации . Также ноутбук не видит ним никаких вайфай сетей. Заранее спасибо .

Сергей
16.11.2018 в 23:12 (7 месяцев назад)

Добрый день. Чтобы хоть что-то вам подсказать, я как минимум должен знать, какая Windows установлена на ноутбуке. Есть ли беспроводной адаптер в диспетчере устройств, что у вас в окне «Сетевые подключения» и какой статус подключения в трее. Можете прикрепить скриншот.

Анастасия
10.12.2018 в 02:29 (6 месяцев назад)

Добрый вечер.У меня аналогичная проблема с Windows 7. Подключение по Wi-Fi есть, но значок говорит об обратном.
Сделала все так, как вы написали. Пошла в компоненты, нашла подозрительный, в моем случае — ESET Personal Firewall, но снятие галочки не помогло. Не помогло так же и удаление компонента. В обеих случаях перезагружала ноутбук. После удаления обнаружила, что этот комонент снова на месте и галочка снова стоит… Что это может быть?

Сергей
10.12.2018 в 12:31 (6 месяцев назад)

Это компонент от вашего антивируса. Возможно, ESET Personal Firewall можно как-то отключить в настройках самого антивируса. Правда не факт, что проблема в этом.

На скриншоте вижу, что у вас статус подключения «Есть доступные подключения». Интернет на компьютере в этот момент работает? Он к Wi-Fi сети подключен?

bypsix2017
09.02.2019 в 23:45 (4 месяца назад)

У меня там тоже от ESET фаервол какой-то Epfw NDIS LightWeight Filter но не в нём проблема. Интернет есть, но значек перечеркнут. Появилось после обновления драйверов на блютуз и установки программы BlueSoleil Всё работает но немного раздражает просто

Анастасия
25.12.2018 в 16:00 (6 месяцев назад)

Да, интернет подключен к Wi-Fi, прекрасно работает, вот только значек говорит об обратном.

Кирилл
29.12.2018 в 14:58 (6 месяцев назад)

Такой вопрос:
Есть пк, к нему подключен USB-модем. От этого пк через патч-корд подключен к свитчу, а от свитча на другие два пк. Интернет есть, все хорошо. Но вот, если перезагружается первый пк(к которому подключен USB-модем), после включения на нем есть интернет, а вот на остальных отсутствует интернет. Горит желтый значок, «без доступа к интернету».
Эта проблема решается постоянным заходом в доступ. Сначала я его убираю — Подтверждаю. Потом опять ставлю галочку с доступом и только после этих манипуляций интернет появляется.
Как избежать этих танцев с бубном?

Сергей
29.12.2018 в 20:56 (6 месяцев назад)

Я понял вопрос. Такая же ерунда часто происходит при раздаче интернета с компьютера по Wi-Fi. Тоже каждый раз приходится выключать/включать общий доступ.

Подозреваю, что причина может быть в настройках службы «Общий доступ к подключению к Интернету». Зайдите в «Службы», найдите в списке эту службу, нажмите на нее правой кнопкой мыши и выберите «Свойства».

Затем в меню «Тип запуска» выберите «Автоматически», нажмите на кнопку «Запустить» и «Применить». Это должно сработать.

Людмила
07.01.2019 в 15:58 (5 месяцев назад)

Спасибо огромное!Всех благ!

Азамат
12.01.2019 в 12:33 (5 месяцев назад)

Кто может помочь
У меня интернет все хорошо работал
А шяс это желтый значок и не работает интернет

Сергей
12.01.2019 в 12:44 (5 месяцев назад)

Смотрите решения вашей проблемы в этой статье: http://help-wifi.com/reshenie-problem-i-oshibok/podklyuchenie-ogranicheno-v-windows-10-po-wi-fi-i-setevomu-kabelyu/

Екатерина
26.01.2019 в 15:55 (5 месяцев назад)

Добрый день! Уже измучила себя с этим интернетом, чего только не пробовала, но все равно не работает и не понимаю , в принципе, в чем проблема. На всех других устройствах wifi работает, а вот на ноутбуке почему то не хочет, при этом, либо «обмежено» либо доступ есть но В поисковике ничего не грузит и пишет «нет подключения к Интернету» . Какие ещё могут быть способы решения этой проблемы , и в чем она вообще ??

Сергей
27.01.2019 в 00:01 (5 месяцев назад)

Добрый день. При подключении к другим сетям интернет работает?
Какая Windows на ноутбуке?

Антон
11.02.2019 в 12:28 (4 месяца назад)

Спасибо огромное!!!
Я все перепробовал не мог понять в чем же проблема и обновлял сетевую и кабели другие пррбывал и к разным маршрутизаторам подключал а тут оказалось все проще, спасибо ещё раз!

Сергей
11.02.2019 в 21:39 (4 месяца назад)

Пожалуйста!

Александр
15.02.2019 в 20:40 (4 месяца назад)

Здраствуйте. Извините, если пишу не в той ветке. Проблема такая. Виндовс 10. Интернет в основном через кабельную сеть, но иногда использую 3g-модем. Браузером пользуюсь,в основном, Мозилой. С ним всё нормально — работает и через сеть и через 3g-модем. Иногда включал microsoft edge, используя кабельную сеть — тоже нареканий не было. Но неделю назад при использовании 3g-модема, запустил microsoft edge. Теперь он работает только через 3g-модем, через кабельную сеть не хочет — «Не удалось открыть эту страницу». Internet explorer — аналогично. А Мозила как работала и через кабель, и через 3g-модем, так и работает. Уже и сброс в свойствах браузера делал- ничего не помогло.

Сергей
15.02.2019 в 20:59 (4 месяца назад)

Здравствуйте. Странная проблема, конечно. А сброс сети Windows не пробовали делать?
Ни один сайт в Microsoft Edge не открывается? Что в других браузерах (кроме Firefox)?

Александр
15.02.2019 в 21:26 (4 месяца назад)

Ни один не открывается, только через 3g-модем. Других браузеров нет. Internet explorer точно так же не хочет через сеть работать, ощущение, что 3g-к прописал какие-то свои настройки в них.

Александр
16.02.2019 в 14:05 (4 месяца назад)

Поставил ещё хром. Включал и через 3g и через сеть, всё в норме. А майкрософтовские чудят.

Сергей
16.02.2019 в 14:22 (4 месяца назад)

Без понятия в чем может быть дело (если сброс настроек сети и самого браузера не помог).

Андрей
16.02.2019 в 01:37 (4 месяца назад)

Добры день всем! Бегло прочитав вопросы хочу поделиться мнением. Вот лично мое: в течении последних семи лет я тесно дружу с компьютером. из них первые три я *защищал* его то авастом то касперским то пандой то еще каким то г…ном.

Итак к чему пришел — никакие антивирусы вам не помогут и не нужны в принципе. хуже того они и есть самый страшный вирус. например если поставить аваст то даже через реестр его не вычистить. не пустит. А что бы не словить вирус просто не лазьте где попало. а если поймали переустанавливайтесь и все дела. а данные умные люди хранят на D диске или на выносном диске или в дроп боксе или на яндекс диске…куча вариантов не потерять инфу. только д..рак ставит систему и все остальное на один диск.

Теперь про потерю связи . Очень часто слетает галка в меню _включить сетевое обнаружение_ Находится это : Идем в панель управления — далее центр управления сетями и общим доступом — далее слева вверху находим *изменить дополнительные параметры общего доступа* щелкаем и в открывшемся меню ставим точку напротив *включить сетевое обнаружение* . Ваш компьютер увидит и проводной модем и беспроводной. болячка у всех одинаковая. особенно для любителей антивируса.

Значит если я вас не убедил то подумайте вот над чем : тот кто написал первый вирус, то написал антивирус. В одном помещении сидят два парня , два друга и один хочет продать антивирус …но угрозы нет а где взять? тогда его друг за соседним компьютером пишет вирус. Так и работают. И касперский и панда и аваст си клинер все без исключения работают по одной схеме. а вы просто не лезьте куда не следует. Лично я пятый год работаю на компьютерах без антивируса и у меня вообще нет проблем. Мне этот вирус не нужен я его не ищу и так называемый антивирус (тот же вирус) не ставлю. и классно живу. Чего и всем желаю . Включайте мозги.

Эмиль
25.05.2019 в 22:48 (3 недели назад)

Почему нету нигде «подключения по локальной сети», везде ищу найти не могу…

Сергей
25.05.2019 в 22:53 (3 недели назад)

Мне нужно больше конкретной информации по вашей проблеме.

Михаил
30.05.2019 в 22:03 (2 недели назад)

У меня похожая ситуация. Интернет есть, значок перечёркнут красным.
В папке: Панель управления\Сеть и Интернет\Сетевые подключения — пусто, поэтому изменить свойства (как у вас описано: Открыл свойства «Подключение по локальной сети») не получается.
Куда дальше копать?

Сергей
30.05.2019 в 22:34 (2 недели назад)

У вас совсем другая проблема.
Можно попробовать переустановить сетевой адаптер. Удалить его в диспетчере устройств. Возможно после перезагрузки компьютера понадобится установить драйвер сетевой карты.

Михаил
30.05.2019 в 22:53 (2 недели назад)

>>переустановить сетевой адаптер
>>Удалить его в диспетчере устройств
>>перезагрузки компьютера
>>установить драйвер сетевой карты
всё это делал, без изменений

Сергей
30.05.2019 в 22:56 (2 недели назад)

К сожалению, не знаю что вам еще посоветовать.
Разве что попробуйте сделать сброс настроек сети в Windows.

Михаил
30.05.2019 в 23:36 (2 недели назад)

>>сброс настроек сети в Windows
это тоже делал

Правила комментирования
1. Все комментарии проходят проверку.
2. Если Вы хотите задать вопрос, то опишите проблему как можно подробнее. Напишите конкретную информацию о проблеме.
3. Комментарии с ненормативной лексикой, оскорблениями, и бессмысленные комментарии будут удалены.
4. Запрещена реклама других сайтов, групп в социальных сетях, спам и т. д.
5. Пожалуйста, пишите грамотно. Не пишите заглавными буквами.
6. При ответе на комментарий, пожалуйста, нажимайте кнопку "Ответить".

Добавить комментарий: